Highlighted
Active Level 3

I'm just frustrated upon this issue. I just bought galaxy m31 two weeks ago,and since then i'm facing this issue, whenever i lock my phone and leave it for sometime, fingerprint unlock doesn't work. However when i open the lock screen by pressing lock button then fingerprint works well. My best guess is I think the fingerprint scanner is being disbaled or being put to sleep whenever the phone is in idle. I'm just too much annoyed by this now. This is my 1st samsung phone,i was using other brands earlier,but this time i chose to go with samsung, now i've Statred to feel like it was a BAD BAD decision. Annoyed beyond words!! What's the point of having a fingerprint  unlock feature if I have to press the lock button every time to activate the fingerprint sensor?????? 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Active Level 4
disable battery optimization for com.samsung.biometrics.
plzz accept my solution if u were helpful.

View solution in original post

Reply
Loading...
15 Comments
Highlighted
Active Level 9
i also have M31 only and fingerprint works fine i dont have any idea regarding face it was slow so i turned it off
you can check in the get help section with interactive checks if the sensor is fine or not
try de registering and then again resgistering
or at last place an error report from the application they will tell you more specific ways to treat it
Reply
Loading...
Highlighted
Tried re-registering, tried turning off battery optimization.. no success yet
Reply
Loading...
Highlighted
place an error report or can use whatsap support also or if its possible show the device at Serivice center(plz take backup in advance if u wanna avoid a 2nd round)
Reply
Loading...
Highlighted
reach the customer care
Reply
Loading...
Highlighted
try applying a fully transparent tape at the rear fingerprint scanner . sometimes it dont work when it is wet...
hope u accept my solution
Reply
Loading...
Highlighted
disabled battery optimization for com.samsung.biometrics as "pheonix01" said and voilla, issue solved😀
Reply
Loading...
Highlighted
from where this is done in case i need it in future
Reply
Loading...
Highlighted
🤍u
Reply
Loading...
Highlighted
Goto settings>apps . The select show system apps from the option on the top right corner. The search for com.samsung.android.biometrics
tap into it and you'll get battery optimization option, in here again search for it from the list, enable/disable button will be there next to it.
Reply
Loading...