Original topic:

Allowed network for apps not working

(Topic created on: 02-05-2024 07:17 PM)
169 Views
irfvtk
Active Level 2
Options
Galaxy S
For My Samsung phone allowed network for apps option not working.
I set mobile data only for Whatsapp, then turn off mobile data, but Whatsapp is using wifi. 
How to solve this..
5 Comments
MOQBALI
Expert Level 2
Galaxy S
If the "Allowed network for apps" option on your Samsung phone is not working as expected, try these steps:

1. **Update Apps:** Ensure that both your system software and WhatsApp are up-to-date. Outdated apps may not properly adhere to network settings.

2. **Check App Permissions:** Verify that WhatsApp doesn't have additional permissions allowing it to use Wi-Fi even when mobile data is restricted. Go to Settings > Apps > WhatsApp > Permissions.

3. **Restrict Background Data:** In addition to the allowed network setting, restrict background data for WhatsApp. Go to Settings > Apps > WhatsApp > Data usage > Background data. Disable it.

4. **Reset App Preferences:** Resetting app preferences can sometimes resolve unexpected behavior. Go to Settings > Apps > three dots (top right) > Reset app preferences.

5. **Restart Phone:** A simple restart can clear temporary glitches. Turn off and then on your phone.

6. **Review Wi-Fi Settings:** Ensure that your Wi-Fi connection is not set to override mobile data settings for specific apps. Check Wi-Fi settings and make sure there are no restrictions there.

7. **Check for Device-specific Updates:** If your Samsung phone has its own system software updates, make sure your device is running the latest version.

0 Likes
irfvtk
Active Level 2
Galaxy S
I am expecting some expert solutions from experts...
All these steps mentioned above are basics .
0 Likes
Samsung_specialist
Community Manager
Options
Galaxy S

As per the concern, we would request to kindly perform the following steps to resolve your issue.

Clear app cache through Device care:
Settings > Device care > Storage > CLEAN NOW.

Note: To delete files or uninstall apps that you do not use anymore, select a category under USER DATA. Then, tick items to select and tap DELETE or UNINSTALL.

The clear cache memory of a particular application:
Settings > Apps > Now pick the app that you like to clear off the cache memory > Storage > Clear Cache.

Reset the device Settings: Settings > General Management > Reset settings>Reset all settings to their default.

irfvtk
Active Level 2
Galaxy S
I am sorry to say that your reply is very disappointing, you should first understand the question correctly and then reply
0 Likes
kragothv
Beginner Level 3
Galaxy S

Have same issue with s24.I  wanted to block wifi access for app.

Given: Wifi On, Mobile data Off.

When: I set in Whatsapp settings:  Usage/mobile data/

  • allow background data usage On
  • allow usage when data saver is on On

Settings/connections/data usage

  • data saver Off
  • Allowed networks for app/Whatsapp/Mobile data only

Force stop whatsapp, clear cache, open.

Then: Whatsap is still using wifi, but it shouldn't.

If I reverse this:

Given: Wifi Off, Mobile data On

When: Allowed networks for app/Whatsapp/Wifi only

Then: I get notification - Whatsapp isnt allowed to use mobile data.

So blocking mobile works, but blocking wifi isnt working.