Highlighted
Ranastro
Beginner Level 2
Im using jio sim on 1st slot. While using the phone on strong signal area it is fine but on low signal area the phone becomes horrible. No signal everytime and internet, youtube doesnot run. But using the same sim on same place with oher phone is flawless. It was with my previous m20 and now on a50. But i want to use samsung branding. So cant we expect a good signal reception from samsung?
95 Comments
Highlighted
Samsung_hk51CxJ
Beginner Level 4

i have the same problem 


@Ranastro wrote:
Im using jio sim on 1st slot. While using the phone on strong signal area it is fine but on low signal area the phone becomes horrible. No signal everytime and internet, youtube doesnot run. But using the same sim on same place with oher phone is flawless. It was with my previous m20 and now on a50. But i want to use samsung branding. So cant we expect a good signal reception from samsung?

 

Reply
Loading...
Highlighted
Pranz
Beginner Level 2

I have the same issue with my a50.

Reply
Loading...
Highlighted
mohammsh0014
Active Level 1

hi.  

download and install   force Lte only  app from google play  and set the two simcard prefered network on  Lte only or Ltr\wcdma  and push  run bottom and then update  and mobile radio on and off. 

your mobile network back to normal . enjoy and share the solution.  tnx

Reply
Loading...
Highlighted
mohammsh0014
Active Level 1

 

hi.  

download and install   force Lte only  app from google play  and set the two simcard prefered network on  Lte only or Ltr\wcdma  and push  run bottom and then update  and mobile radio on and off. 

your mobile network back to normal . enjoy and share the solution.  tnx


@Samsung_hk51CxJ wrote:

i have the same problem 


@Ranastro wrote:
Im using jio sim on 1st slot. While using the phone on strong signal area it is fine but on low signal area the phone becomes horrible. No signal everytime and internet, youtube doesnot run. But using the same sim on same place with oher phone is flawless. It was with my previous m20 and now on a50. But i want to use samsung branding. So cant we expect a good signal reception from samsung?

 


 

Reply
Loading...
Highlighted
v1992
Active Level 1

I'm using the same phone and has same problem.  disspointed like a hell.  SAMSUNG need to fix this as soon as possible

Reply
Loading...
Highlighted
CNC777
Beginner Level 5

Same issue with my a50

Reply
Loading...
Highlighted
Andreeindira
Beginner Level 2

I'm in Indonesia, i bought this phone a week ago. And i have the same problem.

I'll never have an issue about signal on my last phone, but with this phone the signal is so low and poor! Please samsung help us

Reply
Loading...
Highlighted
mohammsh0014
Active Level 1

 

hi.  

download and install   force Lte only  app from google play  and set the two simcard prefered network on  Lte only or Ltr\wcdma  and push  run bottom and then update  and mobile radio on and off. 

your mobile network back to normal . enjoy and share the solution.  tnx

Reply
Loading...
Highlighted
Saqlain747
Beginner Level 3
same problem with me. i've faced this problem before.. i bought this a50 phone 4 months ago.. in beginning it was working good but from 2 months it is not catching good internet signal.. i check all company sim card but same weak connection n when i use my old j7 prime phone with same sim cards it work very well.. i am so angry on Samsung for this phone.. this phone is good in everything but what use of a phone when it can't open even google page..
Reply
Loading...