Original topic:

A40: cannot copy files from W10 PC via USB

(Topic created on: 12-24-2020 05:08 PM)
Beginner Level 2
Galaxy A

When I try to select 'USB controlled by - Connected device' it says 'Couldn't switch'.

Phone is connected via original USB cable to W10 laptop, so should be no issues transferring files.

But when I select files on my PC to copy across, nothing happens when I try to paste them onto the phone's SD card.


Also, I have tried to setup the Your Phone program on my PC, and Link to Windows on the phone, but it says "Something happened - We're having trouble connecting... Wait and try again (Error 53)."

I have tried following ALL of the suggested trouble-shooting so PLEASE whatever you advise, don't just repeat the standard trouble-shooting at me; it hasn't worked.


Phone's software is up-to-date, and PC has all updates installed.


1 Comment
Community Manager
Galaxy A

Hi there,

Please check that the Smart Switch for PC is installed on the PC running on Windows 10. By then simply connect only the phone to the PC and let the installation of driver complete. 

Check this for more info and support https://www.samsung.com/ae/apps/smart-switch/