Original topic:

S20 WiFi shows "Connected without Internet" when Bluetooth is on or Connected

(Topic created on: 03-09-2020 12:17 AM)
Timesking
Active Level 2
Options
Galaxy S
Folks,
I Come from S8 and I recently upgraded to S20.
I had this same problem with my S8 which is not resolved till now. Now I see this problem with S20 also. 
S20 Bluetooth when connected to my JBL wireless earphobes, when I watch some video on YouTube, WiFi  shows like "Connected without Internet". This happens while scrolling through videos or what watch some video. Suddenly WiFi isn't connected. 
This is bothering me. 
Is anyone else facing this issue? 
It's just been 3 days since I purchased this phone. 

17 Comments
Timesking
Active Level 2
Galaxy S
Yes connects to other router but 2.4GHz routers I faced same problem while connected to Bluetooth.
I have sent the error report.

Before doing that tried resetting network settings also.
0 Likes
tduarte
Beginner Level 3
Galaxy S

I had this happen today. it's kind of annoying. the wifi/router is fine but the phone when crazy for a while. after a couple restarts and full shutdowns it when back to normal.

0 Likes
Sushmit174
Beginner Level 2
Galaxy S

I am also facing the same problem on my Note9 for months now. Tried resetting network settings, wiped cache partitions, restarted the router,changed channel on the router. Still no luck. I had connected Oneplus6, mi pad and other devices with the same router, there were no issues on that phone.  

0 Likes
Timesking
Active Level 2
Galaxy S
May be try with 5GHz dual band router as suggested in above conversations.
0 Likes
Quantumdefect
Beginner Level 2
Galaxy S

Hi, if the following is true for you, then the solution which worked for me should work for you too. If you have a mesh network / multiple access points with the same WiFi SSID / dual band network with single SSID, simply disabling Google Location Accuracy in Settings > Location will work. If not, I also have WiFi scanning disabled in Settings > Location > Improve Accuracy.

 

Hopefully it works for you and ends the nightmare.

 

I've contacted Samsung twice now and advised that this solved my problem so if it solves yours too, please comment so it is escalated as something to fix. It seems to only affect Samsung phones of S10 and above.

amoeboid
Beginner Level 3
Galaxy S

I also had this problem for the past 2 weeks.  Tried the following but it didn't fix the issue:

1. Turning off Private DNS

2. Changing to Static IP

3. Using Phone's MAC address instead of Randomized MAC

 

Finally, the solution that worked for me was:  Turning off Google Location Accuracy.  (I also have Improve Accuracy > Wifi Scanning turned off, but that didn't solve it to begin with.  So I don't think it's needed to be off for this fix.)

 

I was able to get stable wifi connection even with the original settings for attempted fix #1-3 above.

 

Hope this helps for those with this annoying issue.

0 Likes
Niente23
Beginner Level 2
Galaxy S

Recently I had this problem showing my WiFi is connected without Internet but other devices were connected to that WIFI,I managed to fix it by going in the (no Internet Wifi)-settings-Mac address type and selecting Phone Mac instead of Randomise Mac and everything is working now.

piobryan
Beginner Level 2
Galaxy S
  • FIXED!!! June 2021
  • Got the same problem with my S20, scour the web for answers did not find any.
  • turns out my Mac Address was “randomized”.
  • go to Wifi > Advanced > Mac address 
  • select Phone Mac
  • solved my problems! Hope yours too.