Highlighted

In many respects, the Galaxy S20 series is the culmination of mobile technologies Samsung has been iterating upon for over half a decade. Wireless charging is no exception as with the Galaxy S20’s Wireless PowerShare feature, Samsung allows you to wirelessly charge other devices with your phone.

Samsung’s 2019 flagships were the first devices to come with Wireless PowerShare and the company has retained the feature for the Galaxy S20 lineup as well.

Samsung Wireless PowerShare explained




Much like its name suggests, Wireless PowerShare allows the Galaxy S20, Galaxy S20+, and Galaxy S20 Ultra to reverse wireless charge other devices. The feature isn’t just limited to Samsung-made handsets and gadgets. Devices that support the Qi charging standard can be wirelessly charged using these handsets.

Be that as it may, Samsung’s always quick to point out that Wireless PowerShare has been specifically designed for its select few products, primarily the Galaxy Watch Active 2 and Galaxy Buds+.

Even in ideal circumstances, the solution can’t really compare to contemporary fast wireless chargers which support speeds of up to 15 watts. In contrast, the wireless charging coil found inside the Galaxy S20 line delivers less than half of that performance, which makes the functionality not something to rely on an everyday basis, but it’s nice to have the option should you need to add some juice to your Galaxy Buds+ when you’re on the road.

How to use Wireless PowerShare on the Galaxy S20

Samsung’s proprietary implementation of reverse wireless charging can be accessed from the Settings app, but the easiest way to enable it on any Galaxy S20 model is from the notification panel. Pulling down twice on any screen should do the trick, presenting you with the relevant toggle on the first shortcut page.


image


Tapping the icon will prompt the phone to start acting as a wireless charger. Do keep in mind that your phone needs to have at least a 30% charge for this to work. With the feature enabled, simply set a compatible device on top of your Galaxy S20, Galaxy S20+, or Galaxy S20 Ultra’s rear panel to start charging it. By default, Samsung’s flagships will signalize the start of a wireless charging connection via a notification prompt.


image


image


On the other hand, interacting with the “Wireless PowerShare” text will lead you to a Settings page dedicated to the service. Choosing the latter lets you tap on “Details” where you’ll be greeted with a short tutorial. This screen is also where you can manually set the battery limit for allowing Wireless PowerShare, ranging from 30% to 90%. There’s no way to go below the 30% limit.

Even if you’re running a custom launcher on top of One UI, the Wireless PowerShare toggle should still be sitting in the notification shade by default. On the off chance that’s not the case, just open the Settings app and look up the feature using the search bar at the top.

11 Comments
Highlighted
Expert Level 5
And what about the problems we S20 series users facing? Have you any idea about that bro?
Reply
Loading...
Highlighted
I myself am a S20+ user. What problem are you facing?
Reply
Loading...
Highlighted
Expert Level 5
1. Heating even when u are just scrolling through apps.
2nd. Games work like its a cheap 5k phone now performance at all.
3rd. Battery performance.
4th. Camera have no details, 30x zoom is jut on papers.
Reply
Loading...
Highlighted
Battery, I'll agree to some extent, but I didn't face any other issues that you mentioned. Maybe get yours checked once at the nearest service centre, when it reopens.
Reply
Loading...
Highlighted
Active Level 5
just a post to improve his chance to become a influencer!!!
Reply
Loading...
Highlighted
This post is to make people with the particular smartphone aware about the feature it packs.
Reply
Loading...
Highlighted
Active Level 1
Is anyone facing lock screen issue with Galaxy S20+?
Reply
Loading...
Highlighted
Fingerprint Not detecting properly?
Reply
Loading...
Highlighted
Active Level 1
Sometimes lockscreen gets freeze while unlocking phone. This has been happening since the last update.
Reply
Loading...