Highlighted
Active Level 3

Samsung phone has been giving headaches to many due to slow charging especially after android 10 update. 

 

Solution is :

1) Update to latest software released recently in June in India

2) If not solved, then go to battery charging option, disable fast charging 

3) if still not solved, again enable fast chargung after 1st disabling it & charging for 30 mins

4) if still not solved, best bet is to charge in morning

5) go to service center if persists

 

I did step 2 & charged 19% in 31 minutes while the network was still on.

Screenshot_20200602-232222_AccuBattery.jpg

11 Comments
Highlighted
Active Level 10
Need to check this.
Reply
Loading...
Highlighted
Active Level 1

I have the charging issue as well on my m30s, i have recently created a post (https://r2.community.samsung.com/t5/Galaxy-M/Samsung-M30s-fast-charging-issues/td-p/4519593)..

 

Have tried all possible troubleshoot from my end.. will try this as well now.. hopefully it works.

Reply
Loading...
Highlighted
Active Level 1

Not working...tried this

Reply
Loading...
Highlighted
Active Level 3

Bro, let me help you in another way. Try this:

Go to Settings - Device care - Memory - Clean now

Then, go to Battery, enable  fast charging & then disable fast charging.

This should give better charging speed. I tried this now & got 3% charged in 5 mins.

Reply
Loading...
Highlighted
Active Level 1
tried that too.. in fact I even tried safe mode, wipe catche from boot screen and finally now wiped all data and factory reset from boot screen.. still no luck
Reply
Loading...
Highlighted
Active Level 1
as you see, while charging it says Cable charging
Reply
Loading...
Highlighted
Active Level 3

For me the above method worked, simply cleaning memory in Device care & disabling fast charging. It then just shows Charging, but charges comparatively faster.. 

I was equally fed up of M30s slow charging, but this method gave some respite.

 

Reply
Loading...
Highlighted
Active Level 3

As you see in your screenshot, free memory is 1.7 gb out of 4gb. Go to Device care, then memory, clean now.

Then go to Battery, enable fast charging & then disable, then start the charging.

Tell me if this works

Reply
Loading...
Highlighted
Active Level 1
tried this, dint help
Reply
Loading...