Roy_M31
Active Level 1
Options
Tech Talk
I have a Galaxy F62 8GB RAM and 128 GB memory. I have been facing some peculiar wifi issues. So whenever I connect to the wifi speeds are comparably slow. The router is in my room and all my other devices work fine.

Whenever I run speed tests it gives me 140+MBPS speeds yet internet speeds don't show up on the phone.

The Mobile data seems to work fine but wifi is the major issue. I have already reset my network settings that has not fixed anything. Really need some help on this.
10 Comments
RajeshKumar21
Expert Level 2
Options
Tech Talk
RESET SETTINGS OF WIFI
OR DO AGAIN CONFIGURATION OF ROUTER WITH YOUR PHONE

I DON'T FACE ANY PROBLEM IN WIFI SPEED !
0 Likes
Roy_M31
Active Level 1
Options
Tech Talk
Will try to reset the router but not sure if that would work
0 Likes
f62_CA
Active Level 6
Options
Tech Talk

atleast u are getting 140 mbps ...i am getting 14 mbps  at max

0 Likes
Roy_M31
Active Level 1
Options
Tech Talk
Yeah but the speeds don't seem to be worth it
0 Likes
akkuakash12
Active Level 1
Options
Tech Talk
Facing the same issue...rest device are showing 20mbps..this device is showing 4mbps
0 Likes
Roy_M31
Active Level 1
Options
Tech Talk
I hope they find a fix for this
0 Likes
akkuakash12
Active Level 1
Options
Tech Talk
All that they are saying reset network setting reset phone reset everything... an still error persist let us know... what a great solution it is
0 Likes
animeshmodi
Expert Level 5
Options
Tech Talk
Also carrier aggregation issue
krishnanayak
Beginner Level 3
Options
Tech Talk
.m
.,.,.,..
0 Likes