Original topic:

Samsung Wallet not supported Fold4

(Topic created on: 09-10-2023 07:20 AM)
275 Views
FMA81
Beginner Level 3
Options
Samsung Pay
There's a strange issue facing on my wife's Samsung fold 4 purchased locally from Bahrain from one of our telco providers.

Every time I install look up Samsung wallet on the play store it shows me a version that is outdated. One that shows a Samsung s7. 

Then proceeds in telling me we'll notify you once available in your region. 

I've done pretty much everything other than resetting the device. I've restarted, cleared the cache, force stopped, cleared the data on play services and play store and other miscellaneous stuff.. 

I then went ahead and downloaded the latest version from a 3rd party website and there it was. Phone isn't supported which is quite strange. This seems to be the only app where we have the issue 

I've got a flip 3 for myself from the same provider and don't have this issue. Wallet is installed and works with our local bank as well as activated on my watch. 

What is odd is why is it downloading a version from the play store that's outdated even though it says Samsung Wallet but with a 3.7 rating with a limited number of downloads. 

On the other hand, when look up the same app on my play store it shows a 4.4 rating with 100m downloads

Any clue what's going on here? 
2 Comments
FMA81
Beginner Level 3
Samsung Pay
So got the update from Samsung. Despite buying it from my provider they're saying my IMEI is not from the Gulf region and doesn't work here.

I'm not entirely sure I understand since the wallet application is a global one but a long story short it won't work
0 Likes
Samsung_specialist
Community Manager
Options
Samsung Pay

Hello,

Kindly make sure to provide the IMEI number of the phone to be able to check its region. However, Samsung wallet is available in Bahrain in 2 banks only ( BBK & KHCB).

0 Likes