cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Sim not registered

(Topic created on: 10-26-2023 07:42 AM)
405 Views
fibi123
Active Level 1
Options
Galaxy S
My phone had disconnected from the network for the last 3 days.
If I'm not in a WiFi zone I have no network connection.
This happened last year with my S21 and Samsung told me to buy a new phone. I bought the Samsung s22 ultra and having the same problem again.
I've contacted Vodacom, reset my settings, swopped my Sims, and still getting not registered on the network 

I have inserted my sims in my iPhone and both works with no issues. Full network connection.
So please don't tell me the problem is not the phone?????

Why is Samsung not fixing this problem??
So many complaints globally about this problem with no fix or notice from Samsung?
13 Comments
DatGuy
Active Level 7
Galaxy S
There could be numerous reasons and solutions so use this as a basic guide to try and see if you can find a fix: https://www.getdroidtips.com/samsung-s22-plus-s22-ultra-not-registered-network/
0 Likes
fibi123
Active Level 1
Galaxy S
I have done everything in this post and still getting same problem.
0 Likes
fibi123
Active Level 1
Galaxy S
Are you still there?
0 Likes
DatGuy
Active Level 7
Galaxy S
I'm at work, break now. Check to see if your devices support vodacom basebands via GSM arena. This shouldn't be an issue these days but it's possible that it is incompatible with the bands, especially if it was designed for specific regions.
0 Likes
fibi123
Active Level 1
Galaxy S
I'm now at the final step of your advice shared.
Contact my network provider.
They have trouble shoot on their end and found now issues
0 Likes
fibi123
Active Level 1
Galaxy S
You do acknowledge that when I put my sim card into an iPhone, I am able to make and receive calls, send messages???
0 Likes
fibi123
Active Level 1
Galaxy S
I have contacted my network provider Vodacom and they have confirmed no issues are with my sim cards.
Tendai777
Active Level 10
Galaxy S
You might need to reset network settings. Or connect your phone using 2g connection only then revert back to automatic(2g/3g/4g/5g)
0 Likes
fibi123
Active Level 1
Galaxy S
I have done this already.
A few times.
There is no change
0 Likes