cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Samsung A21S - Not Showing All Incoming Calls

(Topic created on: 01-23-2021 12:27 AM)
1223 Views
Chris9
Beginner Level 2
Options
Galaxy S

Hi,

 

When I go to Calls, then Recents, my A21S only shows callers from my Contacts list. If I get a call from a new number it doesn't display at all.

 

Elsewhere I saw this suggestion to rectify it:

1. From the home screen, swipe either up or down to access apps.
2. Select Phone.
3. Select Tap on the 3 dots on the top right corner.
4. Select Settings.
5. Select Other call settings.
6. Push slider to activate Show caller information.

 

This (6) was already activated, and doesn't rectify the issue. Additionally I already have "All calls and messages" selected under "Calls to show".

 

How can this issue be resolved?

 

Also, under Call settings, I have "Caller ID and spam protection" turned off. Can someone explain the pros and cons for turning that on please?

 

Thanks, Chris.

 

 

0 Likes
3 Comments
Maps_sam07
Moderator
Moderator
Options
Galaxy S

Hi  Chris9

 

Your Caller Line Identification may need to be activated. Please contact your Network Service provider to activate.

 

*Your network service provider may charge you for this service.

0 Likes
Sunshine3
Beginner Level 2
Galaxy S
I have this EXACT problem and my service provider has turned it on their side various times already.
0 Likes
Deelethaha
Beginner Level 2
Galaxy S
Why does my A21s not showing incoming calls while the phone is still ringing?
0 Likes