Resolved! Solved

Original topic:

Galaxy S20+ issue

(Topic created on: 05-12-2020 08:11 PM)
alpha23
Active Level 1
Options
Galaxy S

I have an s20+ and have been facing some cellular connectivity issue. I currently have an esim as my primary line and a physical nano sim for travelling. The issue I'm facing is that every once in a while calls to my phone will go straight to voicemail. However, I have noticed that this does not happen when the using the phone in dual-sim mode. I have tried the following troubleshooting steps:

  • safe mode
  • factory reset
  • manual network selection
  • contacted service provider

non of these have fixed the problem and if I turn off the physical sim the issue returns. Has anyone faced a similar issue with their s20 series phone?

1 Solution


Accepted Solutions
Solution
MohammedSijah
Expert Level 1
Options
Galaxy S
Also you may try in "3g only' mode.
what if it is the problem of your network.

View solution in context

13 Comments
MohammedSijah
Expert Level 1
Options
Galaxy S
Have you activated call forwarding? Check this.
From any Home screen, tap Phone.
Tap Menu > Settings > Supplementary services.Tap Call forwarding > Turn off everything.
0 Likes
alpha23
Active Level 1
Options
Galaxy S

Yes, I have turned everything off already. It seems weird that everything works fine in dualsim mode but when I switch to the esim only then the problem returns.

0 Likes
MohammedSijah
Expert Level 1
Options
Galaxy S
Remove the voicemail number from your phone and check what it says to the caller now.
0 Likes
alpha23
Active Level 1
Options
Galaxy S

It just says this number is unavailable

MohammedSijah
Expert Level 1
Options
Galaxy S
It proves that, the e sim is not getting registered. But I don't understand how it works in dual mode then.
I am not familiar with e-sim. Better visit your service centre itself. You may try a live-chat too. Please note that before starting the chat itself, describe your problem in detail in the box given. So they can prepare the answer for you.
0 Likes
MohammedSijah
Expert Level 1
Options
Galaxy S
Also ensure that your calls aren’t being forwarded to a third-party calling app, such as Skype. If you have installed any such apps, check app settings.
0 Likes
alpha23
Active Level 1
Options
Galaxy S

I have whatsapp, but I have booted in safe mode to disable all 3rd party apps and still facing the same issue.

Solution
MohammedSijah
Expert Level 1
Options
Galaxy S
Also you may try in "3g only' mode.
what if it is the problem of your network.
alpha23
Active Level 1
Options
Galaxy S

I have tried the 3G mode only which seems to have fixed the problem. I also got a call this morning from Ooredoo advising that they have found an issue in the network and have rectified it. Hopefully this issue doesn't persist now. But the 3G mode was definitely a fix for the issue.