Original topic:

Cellular network issues S23 Ultra

(Topic created on: 02-20-2024 04:33 PM)
114 Views
nick97
Beginner Level 2
Options
Galaxy S
I've been having a tough time with the cellular network on my S23 ultra. I am frustrated with the autoconnect options. I understand not all areas in U.AE have good 5G or 4G+ signals..but I've noticed samsung keeps switching back and fro with 5G to all the way to 4g or 3g in various areas when I move about which therefore disrupts the interent speed on my phone. I wish they disabled the autoconnect button and just stick to a option such has "5G always on" or "4G+ or LTE option"
2 Comments
Zammi
Active Level 8
Galaxy S
It's not completely Samsung related. In the UAE, both Du and Etisalat are in the process of translation into 5G SA (standalone), which is more advanced than current 5G NSA. Most of the connection issues are related to that.

Temporary solution is to switch to LTE.
Samsung_specialist
Community Manager
Options
Galaxy S

Try updating your mobile device's software by following these steps:
Step 1: Go to Settings > Software Update.
Step 2: Tap on Download and Install.
Step 3: Follow the on-screen instructions.
Check if mobile data is enabled on your device.
Force restart your device.
Reset network settings:
Step 1: Go to Settings and select General Management.
Step 2: Select Reset.
Step 3: Choose Reset Network Settings.
Step 4: Follow the on-screen prompts and tap Reset Settings.
Step 5: Tap Reset.

0 Likes