YoYoCoCoCo
Active Level 1
I bought this Note8 in Dubai and it shows my home country as UAE but I live in England.
This means I get a lot of Samsung notifications in Arabic script, or Google will show results in Arabic and many other difficulties with language.
I can't change the Home country because it is grayed out.
Can anyone tell me 'Step by Step' how to change it please?
7 Comments
MittuVichu
Active Level 10
Usually the language that Google and samsung displays will depend on your sim card. Usually for most of the apps it doesn't matter from where is phone is purchased, but the region of sim card matters.
Are you in England right now?
Reply
Loading...
YoYoCoCoCo
Active Level 1
Thank you for your reply. sorry for delay. Yes my sim is from ee in England and is the same sim since 2 previous Samsung phones that didn't have this problem.
Here's an example from today's Bixby page
Reply
Loading...
MittuVichu
Active Level 10
What you see in Arabic is suggestions from YouTube.
This issue is generally associated with your Google account. Try opening your Google account and set default language to English. Do you have this issue in any app other than bixby?
For language issues in browser,
Type www.google.com in your browser. From there just below the search bar you can select language to English. After that login to your Google account from the browser.
Reply
Loading...
YoYoCoCoCo
Active Level 1
That's very helpful. I did understand about the YouTube suggestion but they are ALL in Arabic & I want English.
I have set Google to English as your advice, thanks.
However things have not improved. I post three screenshots JUST taken. You will see that one of them is a notice from SAMSUNG in Arabic found in my Settings today.
The two Google screenshots are AFTER I set English in www.google.com.
I think the Home Country needs to be set to UK but of course this is greyed out & I can't do anything.
it's a problem - I don't know Arabic Smiling Face)
Reply
Loading...
targetDrone
Active Level 1
I have the same issue. Not quite as severe as yours as Android itself isn't throwing Arabic at me. Everything samsung though insists I am in the UAE when I'm in the UK using a UK sim with UK google settings.

If you go to the samsung website, there is no option to change your country, but if you open a support ticket, they can do it, which was good as the site was all in Arabic (despite my browser language list being various Englishes...) and it doesn't work through google translate.

Unfortunately though, that doesn't help.
Reply
Loading...
YoYoCoCoCo
Active Level 1
This seems to be common with UAE. I bought mine jn Dubai but everything is set to English, I have English SIM from ee. If Samsung acknowledged my Home Country is stuck on UAE and being greyed out I can't change it but they did it would be Problem Solved.
Reply
Loading...
RJHin
Active Level 1
Try searching for Roaming Clock in Settings. Turn on and select your Home Tone Zone and see if that helps. I fixed this many months ago and forgot how but I think this was it
Reply
Loading...