Original topic:

Esim not enabled?

(Topic created on: 12-29-2021 07:17 PM)
Chikai
Active Level 1
Options
Galaxy Note
I've got the note 20 ultra N9860ZSS3DUK4
and cannot find esim option

Need help!
3 Comments
Galaxy Note
You may check under sim card manager in settings. Settings >> Connections >> Sim card manager. Screenshot_20211229-181738_Call settings_88705_1640791058.jpg
0 Likes
Chikai
Active Level 1
Galaxy Note
no esim option here :(SmartSelect_20211229-195646_Call settings_51072_1640793502.jpg
0 Likes
SHINAN-EpFBz
Active Level 7
Galaxy Note
you many need to change the country and update
0 Likes