Highlighted

Dear Samsung Member,

Greetings from Samsung Customer Support!


Please perform the below mentioned steps to resolve the issue:

 

1. Check network operator settings
Settings > Connections > Mobile networks > Network operators > Select automatically > OK > Registered on network.

Note: We recommend to set device network operators as LTE/3G/2G (auto connect) mode.

 

For further assistance, register your concern in Samsung Members Application (Open Samsung Members Application > Get help > Send Feedback > Error report/Ask questions).


Thank you for writing to Samsung.

 

Warm Regards,
Samsung Customer Support

Reply
Loading...
Highlighted
Active Level 1
Dear Samsung,

Thanks for reply. Above mentioned steps have been performed by me and also replaced the SIM by new one. But doesn't show any improvement in terms of network connectivity. Same Sim is working very well in another phone. I found that there is no option for 4G in network mode.

Hope you understand my concerns.

Thanks
Reply
Loading...
Highlighted
Active Level 1
Samsung Galaxy m21 has low sar value so we will fase low network low net speed....this is a hardware problem..there is no solution for this.
I'm also m21 user facing network problem..I'm using my old non Samsung mob for internet.
Reply
Loading...
Highlighted
Active Level 1
ok thanks.
Reply
Loading...