cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

my A7 2017 is not charging fast.. I tried more Samsung original chargers

(Topic created on: 03-19-2018 11:35 PM)
Sha5746
Beginner Level 2
Options
Galaxy A
hi
0 Likes
2 Comments
Ulfat1
Beginner Level 2
Options
Galaxy A
hello
0 Likes
Farshad1
Active Level 3
Options
Galaxy A
change your cable and open settings>device and maintenance>battery>advanced settings(options button on the top right corner and finally enable the fast cable charging
0 Likes