Highlighted
Active Level 4
The battery of Samsung galaxy a51 is pathetic .
The battery drains very quickly even after taking all measures i.e putting apps to sleep etc. 
But still the problem is not solved 
Can anyone please help me 
6 ACCEPTED SOLUTIONS

Accepted Solutions
Highlighted
Active Level 7
same issue bro on s9

View solution in original post

Reply
Loading...
Highlighted
Active Level 3
exynos processors are the worst. They should start using snapdragon in asian versions too.
please check this petition
http://chng.it/KzHLngSH

View solution in original post

Reply
Loading...
Highlighted
Beginner Level 5
Reply
Loading...
Highlighted
Active Level 10
Enter safe mode and observe your devices battery backup
Guide to enter safe mode.
1Power off the device.
2Now turn on your device by pressing the Power key . When Samsung logo appears, press and hold the Volume down key .
If your device functions correctly in Safe Mode, it is most likely that the issue lies with a 3rd party application that can be uninstalled to resolve the problem

View solution in original post

Reply
Loading...
Highlighted
Active Level 10
Try these things to save your device battery
1. Settings >developer option >background process limit >choose no background process
2. Disable auto sync
3. optimise your device often using with device care app
4. on device care app >battery >3vertical dots >settings > put unused apps to sleep
5.Disable always on the display >if u don't use,
6. On the device care app>battery >disable background process which apps consumes most the battery
7. Turn of Gps, Bluetooth when not in use

doing this things can may help your device battery last longer

View solution in original post

Reply
Loading...
Highlighted
Active Level 3
same with me . i contacted samsung technical team . they said that they will fix this in the upcoming update

View solution in original post

Reply
Loading...
10 Comments
Highlighted
Active Level 7
same issue bro on s9

View solution in original post

Reply
Loading...
Highlighted
Active Level 3
exynos processors are the worst. They should start using snapdragon in asian versions too.
please check this petition
http://chng.it/KzHLngSH

View solution in original post

Reply
Loading...
Highlighted
Beginner Level 5
Reply
Loading...
Highlighted
Active Level 10
Enter safe mode and observe your devices battery backup
Guide to enter safe mode.
1Power off the device.
2Now turn on your device by pressing the Power key . When Samsung logo appears, press and hold the Volume down key .
If your device functions correctly in Safe Mode, it is most likely that the issue lies with a 3rd party application that can be uninstalled to resolve the problem

View solution in original post

Reply
Loading...
Highlighted
Active Level 4
okay will try this also
Reply
Loading...
Highlighted
Active Level 10
👍
Reply
Loading...
Highlighted
Active Level 10
Try these things to save your device battery
1. Settings >developer option >background process limit >choose no background process
2. Disable auto sync
3. optimise your device often using with device care app
4. on device care app >battery >3vertical dots >settings > put unused apps to sleep
5.Disable always on the display >if u don't use,
6. On the device care app>battery >disable background process which apps consumes most the battery
7. Turn of Gps, Bluetooth when not in use

doing this things can may help your device battery last longer

View solution in original post

Reply
Loading...
Highlighted
Active Level 4
I had tried all
Reply
Loading...
Highlighted
Active Level 3
same with me . i contacted samsung technical team . they said that they will fix this in the upcoming update

View solution in original post

Reply
Loading...