strangedhruv
Active Level 3
Options
Galaxy A
I've galaxy a50 & whenever i am keeping this phone in my pant's pocket it is unlocking itself automatically, this is very risky because it is operating by itself. Randomly its calling someone or messaging people and even opening each and every apps co constantly.... very disappointed with samsung. Please give me a solution to this issue.. or release an update to fix this problem.
0 Likes
Comment
naum
Active Level 4
Options
Galaxy A
if all this doesn't work then go for service center
0 Likes
Reply
sam444
Active Level 4
Options
Galaxy A
go to setting then advance features and motion n gestures and then off the lift to wake up feature
0 Likes
Reply
Sidhabhi
Options
Galaxy A
Please, check if your device supports secure lock settings or not..? If it does, then follow these steps;

1) Go to settings
2) Select Lock screen
3) Select Secure lock settings
4) Turn on lock instantly with the power key
5) Also change the duration of Lock automatically option to Immediately..
0 Likes
Reply
gouu
Active Level 2
Options
Galaxy A

I am also facing this issue ..Super annoying ..How to fix ?

0 Likes
Reply
strangedhruv
Active Level 3
Options
Galaxy A
turn off everything on smart lock
0 Likes
Reply
gouu
Active Level 2
Options
Galaxy A
did you solve the issue
0 Likes
Reply
strangedhruv
Active Level 3
Options
Galaxy A
yes
0 Likes
Reply
ShankarGorli
Active Level 1
Options
Galaxy A

I did the same let see it's works noy

0 Likes
Reply
saxonvincent
Active Level 2
Options
Galaxy A

The issue is with the fingerprint scanner. Once you remove the fingerprints and choose unlocking option as pin or pattern, the phone will not auto unlock. I know, it's a bummer, but there is no other way. Unfortunately the scanner is faulty. Samsung should recall and replace / refund all the Galaxy A50s.

0 Likes
Reply
saxonvincent
Active Level 2
Options
Galaxy A

Guys ..

I think I just might have solved the issue.

I was pondering around what might be the issue and figured it out that it might be the problem with proximity sensor not working in tandem with fingerprint sensor.

 

My points:

When you enable double tap to wake and accidental touch off is kept off, the phone will still not wake up if you engage the proximity sensor (cover it with your palm). No matter the accidental touch protection is on or off, double tap to wake will not work if proximity sensor is detecting your body part.

So that means even the proximity sensor is working fine. Because screen perfectly switches off during calls.

So the issue might be a software bug in accidental touch protection settings and that hopefully can be rectified by a software update from Samsung.

 

Now the resolution regarding unlock in pocket:

Turn on double tap to wake.

Switch on or off accidental touch protection. (I didn't find a difference being it on or off, yet better keep it on I guess.) 

Now remove your finger prints and add them again. Don't anable touch to show fingerprint, because in this case, screen will still wake up even if proximity sensor is engaged and thus will drain more battery. 

And the phone will not unlock in pocket!!! 🤗

 

It's working for me, you guys please give it a try and let me know. I guess the double tap to wake keeps the proximity sensor active and somehow clears the issue.

0 Likes
Reply