Original topic:

Very slow charging on the A54 when using a 25w charger

(Topic created on: 06-26-2023 11:01 PM)
218 Views
akaElkhayat
Beginner Level 3
Options
جالاكسى A
The Galaxy A54 supports 25w "Super Fast Charging" but when I use a compatible 25w charger and cable with PPS support it charges at 15w max, after research and several experiments I discovered that the charging throttles that much due to overheating, but when I turn off the phone *even with the same phone temperature* the phone charges at a constant 25w normally.. so the throttling only applies when the phones is turned on.

I understand that this is to limit damage to the battery due to heat but the throttling threshold is really low! in some countries like Egypt (which is where I live) the temperature can reach 45° which can lead the phone to overheat a bit so I'm basically always charging at 15w speed!

I'm pretty sure this is a mistake or a bug because I've tried charging a Galaxy M52 which supports the same 25w charging and it charged at a constant 23w with some spikes to 25w every now and then.

I hope Samsung solves this issue in the next june update.
2 Comments
Samsung Admin
Community Manager
Options
جالاكسى A

Hello. I’m Amira, Samsung Moderator
Thank you for asking the question
We wish you a happy day
Based on your inquiry regarding the update

Based on your question from the above, I ask your permission to follow the following steps
USB Have you tried another charger from the device or
Is the battery original or not
Is there any problem or breakage in the charging socket?
Is there a problem with the charger used?
Is there any swelling in the battery?
Ensure that the charger is original
If the problem persists
Please factory reset the device.
settings
← Public administration
→ Reset
→ Factory data reset
→ Reset
← Clear all.
Before starting this step, please copy the phone data. It can be stored through the following link for the program
Samsung smart switch
http://www.samsung.com/eg/support/smartswitch/

 

If you have any other question, can you explain it to us
We are  at your service always
Thanks for your time

0 Likes
Omarmahmoud1
Active Level 3
جالاكسى A
I have the same problem on my M52 5g